vue中使用scss_百厌_前端开发者

第一步

第一步

安装scss依赖,cnpm i node-sass sass-loader -D

安装scss依赖,cnpm i node-sass sass-loader -D
cnpm i node-sass sass-loader -D

注:sass-loader用来解析scss文件(-D 是 –save-dev 的简写)

注:sass-loader用来解析scss文件(-D 是 –save-dev 的简写)

第二步:

第二步:

在build文件夹下的webpack.base.conf.js的rules里面添加配置

在build文件夹下的webpack.base.conf.js的rules里面添加配置

{

{

test: /\.scss$/,
loaders: [‘style’, ‘css’, ‘sass’]
}
 
第三步:

scss使用测试:如下测试修改字体颜色

 <style lang=”scss”>

$color:red;
div {color:$color;}
</style>
 

安装完成后,运行时出现了错误

Modele build failed: TypeError: this.getResolve is not a function at Object.loader...

这是因为当前sass的版本太高,webpack编译时出现了错误,只需要换成低版本的就行,下面说一下修改方法,

找到package.json文件,里面的 “sass-loader”的版本更换掉 就行了。

安装的sass-loader的版本为最新8.0.0 改成如下即可

 

“sass-loader”: “^7.3.1”

 

然后重新安装项目依赖

在终端执行 npm i

之后启动项目 npm run dev

项目启动成功,编译报错问题解决

 
test: /\.scss$/,

test: /\.scss$/,

loaders: [‘style’, ‘css’, ‘sass’]

loaders: [‘style’, ‘css’, ‘sass’]

}

}

 
第三步:

第三步:

scss使用测试:如下测试修改字体颜色

 <style lang=”scss”>

$color:red;
div {color:$color;}
</style>
 

安装完成后,运行时出现了错误

Modele build failed: TypeError: this.getResolve is not a function at Object.loader...

这是因为当前sass的版本太高,webpack编译时出现了错误,只需要换成低版本的就行,下面说一下修改方法,

找到package.json文件,里面的 “sass-loader”的版本更换掉 就行了。

安装的sass-loader的版本为最新8.0.0 改成如下即可

 

“sass-loader”: “^7.3.1”

 

然后重新安装项目依赖

在终端执行 npm i

之后启动项目 npm run dev

项目启动成功,编译报错问题解决

 

scss使用测试:如下测试修改字体颜色

scss使用测试:如下测试修改字体颜色

 <style lang=”scss”>

 <style lang=”scss”><style lang=”scss”>

$color:red;
div {color:$color;}
</style>
 

安装完成后,运行时出现了错误

Modele build failed: TypeError: this.getResolve is not a function at Object.loader...

这是因为当前sass的版本太高,webpack编译时出现了错误,只需要换成低版本的就行,下面说一下修改方法,

找到package.json文件,里面的 “sass-loader”的版本更换掉 就行了。

安装的sass-loader的版本为最新8.0.0 改成如下即可

 

“sass-loader”: “^7.3.1”

 

然后重新安装项目依赖

在终端执行 npm i

之后启动项目 npm run dev

项目启动成功,编译报错问题解决

 
$color:red;

$color:red;

div {color:$color;}

div {color:$color;}

</style>

</style>

 

安装完成后,运行时出现了错误

Modele build failed: TypeError: this.getResolve is not a function at Object.loader...

这是因为当前sass的版本太高,webpack编译时出现了错误,只需要换成低版本的就行,下面说一下修改方法,

找到package.json文件,里面的 “sass-loader”的版本更换掉 就行了。

安装的sass-loader的版本为最新8.0.0 改成如下即可

 

“sass-loader”: “^7.3.1”

 

然后重新安装项目依赖

在终端执行 npm i

之后启动项目 npm run dev

项目启动成功,编译报错问题解决

安装完成后,运行时出现了错误

安装完成后,运行时出现了错误

Modele build failed: TypeError: this.getResolve is not a function at Object.loader...

Modele build failed: TypeError: this.getResolve is not a function at Object.loader...Modele build failed: TypeError: this.getResolve is not a function at Object.loader...

这是因为当前sass的版本太高,webpack编译时出现了错误,只需要换成低版本的就行,下面说一下修改方法,

这是因为当前sass的版本太高,webpack编译时出现了错误,只需要换成低版本的就行,下面说一下修改方法,

找到package.json文件,里面的 “sass-loader”的版本更换掉 就行了。

找到package.json文件,里面的 “sass-loader”的版本更换掉 就行了。

安装的sass-loader的版本为最新8.0.0 改成如下即可

安装的sass-loader的版本为最新8.0.0 改成如下即可

 

“sass-loader”: “^7.3.1”

“sass-loader”: “^7.3.1”

 

然后重新安装项目依赖

然后重新安装项目依赖

在终端执行 npm i

在终端执行 npm inpm i

之后启动项目 npm run dev

之后启动项目 npm run dev
npm run dev

项目启动成功,编译报错问题解决

 
» 本文来自:前端开发者 » 《vue中使用scss_百厌_前端开发者》
» 本文链接地址:https://www.rokub.com/73248.html
» 您也可以订阅本站:https://www.rokub.com
赞(0)
64K

评论 抢沙发

评论前必须登录!